Delays in Email Sending and Processing
Incident Report for Dover
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 17:38 UTC
Monitoring
We are starting to see the GMail service recover. We will continue to monitor closely before marking as Resolved.
Posted Sep 13, 2024 - 17:18 UTC
Investigating
Our email processing partner is experiencing issues syncing data with Google and Gmail Services. They are actively investigating.

We apologize for the inconvenience and appreciate your patience. If you have any questions or concerns, please contact our support team.

We will provide further updates as information becomes available
Posted Sep 13, 2024 - 16:22 UTC