Email sending and processing is experiencing delays

Incident Report for Dover

Resolved

This incident has been resolved.
Posted May 22, 2025 - 12:48 EDT

Monitoring

Our email integration partner Nylas is experiencing issues with their systems which may lead to delayed email processing, email sending and emails not fully loading within the ATS.

Refer to Nylas's status page https://status-v2.nylas.com/incidents/pqsmmgzw5vb7 for additional updates.
Posted May 21, 2025 - 17:59 EDT
This incident affected: Third Party Integrations (Nylas Email API) and Dover ATS, Dover Sourcing Browser Extension.